Добро пожаловать, Гость
Логин: Пароль: Запомнить меня

Installation Problem PHP
(1 чел.) (1) гость
  • Страница:
  • 1

ТЕМА: Installation Problem PHP

Installation Problem PHP 15 года, 7 мес. назад #840

  • scyphian
  • Вне сайта
  • Fresh Boarder
  • Постов: 4
  • Репутация: 0
Предустановочная проверка EG
выдает следующую ошибку

Проверка php.ini: include_path содержит .: ini_get('include_path')='./:/usr/lib/php/:/usr/lib/php/4.4.7/:/usr/share/php/pear/:/usr/share/php/modules/:/usr/share/php/4.4.7/modules/'
include_path need to contain \".\" - the current directory*

Может ли повлиять на работу системы в целом игнорирование этой ошибки?

Пока с этой ошибкой отказывается устанавливаться только
лишь WEB-mail
Подскажите пожалуйста:
1. Как бороться с той ошибкой
2. Как все-таки установить встроенный web-mail в EG


Характеристики системы Altlinux Server 4.0
PHP 4.4.4 Apache 1.3.xx

Модули которые не устанавливаются
FeLaMiMail
Post-install Dependency Failure* felamimail-Post-install Dependency Failure*:(appname: egw-pear; versions: 1.4.000,1.5; appname: phpgwapi; versions: 1.3,1.4,1.5; appname: emailadmin; versions: 1.3,1.4,1.5; appname: egw-pear; versions: 1.4.000,1.5; ))P 1.4

ПОМОГИТЕ!!!!<br><br>Сообщение отредактировано: scyphian, в: 2007/07/04 00:57

В ответ на:Installation Problem PHP 15 года, 7 мес. назад #842

  • scyphian
  • Вне сайта
  • Fresh Boarder
  • Постов: 4
  • Репутация: 0
В журнале ошибок обнаружил следующее
Web mail так и не подхватился

S Id Tans. Date App. User Sno TimeStamp S Code Error Msg

File Line
W 1 2007/07/03 - 23:15 felamimail , 0 2007/07/03 - 23:15 W PGMERR Programmer failed to pass __FILE__ and/or __LINE__ in next log message
/var/www/html/egroupware/phpgwapi/inc/class.error.inc.php 93
1 2007/07/03 - 23:15 W Permissions Attempted to access 'felamimail'

В нерусских источниках пишут что
дело возможно в том что под Linux не все расширения
PEAR могут быть установлены и отсылают на FAQ
который на \&quot;родном\&quot; немецком языке
www.egroupware.org/index.php?page_name=w...amp;wikipage=FAQde#4

Хотя и отсюда понятно что нужно проаддейтить PEAR
(у меня Под AltLinux 4.0 + Sisyphus PEAR 1.3.4.)
и обязательно установить модули Net_Socket Auth_sasl Net_Sieve
и какой-то необнаруженный мною HTTP_WebDAV_Server-
Подскажите что это за HTTP_WebDAV_Server-
и удалось ли кому-то настроить под Linux (Желательно ALT)
Egroupware ???

В ответ на:Installation Problem PHP 15 года, 6 мес. назад #864

  • bmp13
  • Вне сайта
  • Fresh Boarder
  • Постов: 3
  • Репутация: 0
HTTP_WebDAV_Server можно скачать по адресу: pear.php.net/package/HTTP_WebDAV_Server

Установка производится просто из командной строки : pear install HTTP_WebDAV_Server.tgz только одно но php должен быть собран с поддержкой архивов tar. Как он собран в altlinux не подскожу. Я собирал из исходников под FreeBSD.

P.S. на сайте pear.php.net/ по поиску сможешь найти все другие php модули которые нужны egw
jabber: Этот адрес электронной почты защищен от спам-ботов. У вас должен быть включен JavaScript для просмотра.
  • Страница:
  • 1
Модераторы: admin, vader666
Время создания страницы: 0.21 секунд